Clicky

I have a new Windows 7 Pro PC which I can remote desktop to on my network (192.168.0.100) but if I try to connect out of my network (24.xxx.78.xxx:3389) I get the message, “Remote Desktop can’t connect to the remote computer”. I have my router port forwarded (start 3389 – end 3389 to 192.168.0.100). What do I do to try and fix this?

Phil

asked 12/09/2011 10:40

philschwartz's gravatar image

philschwartz ♦♦


10 Answers:
Opening 3389 to internet exposes your computer to attacks so I recommend you remap a random port above 20000 to internal port 3389.
link

answered 2011-12-09 at 20:11:24

Toxacon's gravatar image

Toxacon

I can't see where the above answers address my particular problem.

Phil
link

answered 2011-12-10 at 01:07:05

philschwartz's gravatar image

philschwartz

Well, if you have a NAT in your router, you propably have a firewall in it as well. Have you opened the required ports? Also make sure that you forwarded TCP/3389.
link

answered 2011-12-10 at 04:41:41

Toxacon's gravatar image

Toxacon

You need to enable RDP on remote side through firewall.


Type the following at the command prompt, and press ENTER:

netsh firewall set service type = remotedesktop mode = enable
link

answered 2011-12-10 at 06:24:04

Russell_Venable's gravatar image

Russell_Venable

Tried above, still have the problem

Phil
link

answered 2011-12-10 at 09:53:44

philschwartz's gravatar image

philschwartz

Can you hook the ethernet cable directly into your machine and not the router and  try to see if you can connect directly that way?
link

answered 2011-12-10 at 20:23:21

Russell_Venable's gravatar image

Russell_Venable

I have a Netgear CD3000D-RG gateway which is a router/modem so I can't plug the ethernet cable directly into my PC

Phil
link

answered 2011-12-11 at 00:00:31

philschwartz's gravatar image

philschwartz

I found in my McAfee a place to check allow access to port 3389, which I did and it is working now.

Phil
link

answered 2011-12-11 at 05:23:54

philschwartz's gravatar image

philschwartz

I found in my McAfee a place to check allow access to port 3389, which I did and it is working now.

link

answered 2011-12-11 at 09:20:42

philschwartz's gravatar image

philschwartz

Your answer
[hide preview]

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Tags:

×1

Asked: 12/09/2011 10:40

Seen: 234 times

Last updated: 12/15/2011 05:16

Related questions