Clicky

I setup FileZilla on Windows Home Server and tested my connection on ftptest.net successfully but I do not see the folders and cannot successfully copy files.
It has to be a FileZilla setup issue but I cannot figure it out.

asked 08/06/2011 06:05

AD_Tech's gravatar image

AD_Tech ♦♦


18 Answers:
Did you create users in FileZilla server and grant them read or write access to shares / folders on your WHS machine?
link
gerwinjansen's gravatar image

gerwinjansen

yes I did. I created 2 groups also.
link
AD_Tech's gravatar image

AD_Tech

I just shared a folder in Users on Filezilla to my user file. Now I see a folder when I ftp but the folder is the name of my user and the folder is in the FTPusers folder on c:\.
The instructions at: http://computingondemand.com/filezilla-ftp-server-on-whs say to create FTPusers on the c, and share the folders through Filezilla's interface (through groups, not users) that are shared on whs.
link
AD_Tech's gravatar image

AD_Tech

I just manually create a folder like c:\ftp_home and create a subfolder for each user that I want to give access. You can create multiple shared folders like c:\data - c:\programs etc. and create aliases to c:\ftp_home\data and c:\ftp_home\programs, set c:\ftp_home as Home directory for the user and you're done. If you can't get it to work, let us know how you would plan your ftp access (for one user) so we can create you a sample.
link
gerwinjansen's gravatar image

gerwinjansen

Yes, I was able to recreate what you did above successfully. Thank you.

What isn't working is when I use groups and try to connect to my WHS "windows home server".

The way you showed me (users) is working and I can use it for now but I really wanted to set it up like the link about.
link
AD_Tech's gravatar image

AD_Tech

I've tested when using groups. I setup a group ftpusers with homedirectory d:\ftp_home and a d:\download folder with a /download alias

The autocreate checkmark causes creation of d:\ftp_home<username>

I created a test user, put it in the group ftpusers and gave the users no rights or shared folders.

Logon as the test user shows the /download directory and creating a 'test' folder results in a folder d:\ftp_home<username>\test

This works OK for me.

Where exactly do you get errors when trying to give rights to the WHS shares?
link
gerwinjansen's gravatar image

gerwinjansen

I actually connected to the FTPusers folder but could not see any folders (just an empty /folder.
I could not ftp anything to this empty / folder

It has to be the way I am configuring the FileZilla software.

I will test what you did above and get back to you.
Thank you.
link
AD_Tech's gravatar image

AD_Tech

This sounds like an issue with your Passive FTP settings. The server is connecting on port 21 for the initial connection, but with passive mode, it switches to a separate port when you list directory contents, copy files, change folders (data transfer).



To fix this issue:

  • Make sure those ports are open in the server firewall (hardware firewall/software Windows Firewall, etc.)

  • Make sure this port range is forwarding to the WHS server in your network.

  • Make sure those ports are open in your client outbound firewall ruleset.
link
pete-mcpetey's gravatar image

pete-mcpetey

You may have to stop/start the ftp server to be sure all settings are applied. I added some screenshots of the working configuration I made. Note with 2nd image: I've set the same security for both the Home folder and the download folder.
 
group ftp 1
group ftp 1
 
 
group ftp 2
group ftp 2
 
 
user ftp 1
user ftp 1
 
 
user ftp 2
user ftp 2
 
link
gerwinjansen's gravatar image

gerwinjansen

gerwinjansen:
That worked. Thank you.

pete-mcpetey:
I will research this. Thank you.

link
AD_Tech's gravatar image

AD_Tech

still can't connect outside of my network. must be a router issue.
link
AD_Tech's gravatar image

AD_Tech

> must be a router issue
Maybe, what network components (switches/routers/modems etc) are there between your FTP client and the (WHS) server you are trying to FTP to?
link
gerwinjansen's gravatar image

gerwinjansen

Belkin Router  N450         F9K1003 v1 (01A)

Optonline Cablevision ISP     Modem - arris tm802g
link
AD_Tech's gravatar image

AD_Tech

Hi, looked at your modem, cannot find any options that mention a built-in firewall.

Your router however has a built-in firewall that needs to be configured in case you want to allow access from outside to your WHS server using FTP. I'm assuming that you didn't do this already.

What you have to do is to forward port 21 for FTP to your WHS server using this procedure. I'm assuming that your WHS server is connected wired to your router.

The procedure above is for setting up access from outside your network, you should be able to test FTP funtionality from inside using a wired or WiFi connection.

Note that you should set a difficult password for the user your'e granting FTP acces from the outside. This to prevent unauthorized access from the outside. You should monitor your FTP server logs and WHS logs as well.
link
gerwinjansen's gravatar image

gerwinjansen

Yes, I have port 21 open to my WHS. I will test with the open port check tool tonight.
Thank you.
link
AD_Tech's gravatar image

AD_Tech

Try resetting your router. Port 21 will work but passive FTP switches to an alternate, random port which needs to be open in your outbound firewall and router config.
link
pete-mcpetey's gravatar image

pete-mcpetey

FileZilla on WHS is now working. I reset the router and then ran the WHS connection configuration again. This worked.

Thank you all
link
AD_Tech's gravatar image

AD_Tech

Great you've got it working :) Thanks for your feedback!
link
gerwinjansen's gravatar image

gerwinjansen

Your answer
[hide preview]

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Tags:

×2
×33
×2
×4

Asked: 08/06/2011 06:05

Seen: 745 times

Last updated: 08/22/2011 07:47