Clicky

I have a Windows 7 workgroup PC on an internal network. I've set up an FTP server on this machine, as we need to pull some large files down from this network to our own network. However, I seem to be having some issues with the Windows 7 Firewall configuration.

The FTP works fine inside the network. The machine's network location profile is set to "Work". The FTP allow rules (both inbound and outbound) are enabled for All Profiles. The router is configured to pass TCP ports 20 + 21 directly to the internal address of this PC. However, when trying to establish a remote FTP connection, it simply times out.

The bizarre thing is, I tried switching the Windows Firewall off for Home or Work (Private) networks, and was still unable to connect from an outside location. However, if I disable the Public networks firewall, I can connect from outside without any issue.

So, this is more a question of my wanting to understand what's going on?! Is this some sort of bug? Surely, if the FTP firewall rules apply to all Profiles, it shouldn't matter what type of network the machine's connected to. But the fact that it's connected to a "Private" network, but disabling the "Public" firewall allows the traffic to flow is confusing me.

Am I misunderstanding how the Windows Firewall is supposed to work?

asked 12/01/2011 09:06

perfectpenguin's gravatar image

perfectpenguin ♦♦


4 Answers:
go to windows firewall then on right pane click advance settings , new window will popup , on inbound rules right click then new rule choose port then choose tcp , fill port number 21 , then allow the connection , then select all profiles then finish ,repeat same for outbound
link

answered

jordannet's gravatar image

jordannet

Thank you. It seems to work now, although it would seem this was only part of the problem.

I noticed I could connect with the command-line FTP client after applying the port rule, but still had problems with IE, Windows Explorer and Firefox. I had to disable the "Use Passive FTP" option in IE to get IE and Windows Explorer working. Presumably this is a router-based issue.

I still wonder why the default FTP rules, pre-defined in the Advanced Firewall configuration do not appear to work.

Anyway - appreciate the remarkably simple solution :o)
link

answered 2011-12-02 at 05:43:50

perfectpenguin's gravatar image

perfectpenguin

never use IE , use ftpzilla client , its best one for transfer ftp ..
http://filezilla-project.org/download.php
link

answered 2011-12-02 at 06:40:50

jordannet's gravatar image

jordannet

Thanks, I'll give it a shot!
link

answered 2011-12-02 at 06:44:51

perfectpenguin's gravatar image

perfectpenguin

Your answer
[hide preview]

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Tags:

×33
×9
×133
×1

Asked: 12/01/2011 09:06

Seen: 198 times

Last updated: 12/01/2011 10:42