Clicky

Hi,

I've been using a self-written program/script for quite a while now that initiates copying of the config file to an tftp server by writing to the router via SNMP. I've used the SNMP MIB entry .1.3.6.1.4.1.9.2.1.55.x.x.x.x (with x.x.x.x being the TFTP server IP), writing the file name as a string to that entry. This has worked for just about any Cisco router and switch we have, up to an ASR1002F (running 15.0(1)). We have just put in a 1001 with IOS 15.1(3)S1, where the snmpset fails - the command itself timeouts, even blocking further snmp read commands from the same source for a while. I've been trying to find documents on which MIB entry I might have to use instead of that old entry, but to no avail ... does anybody happen to know if there's a replacement entry, or whether this might be a bug in the IOS?

Thanks!

asked 11/29/2011 03:41

Garry-G's gravatar image

Garry-G ♦♦


4 Answers:
Not sure, have you tried used a MIB browser to locate the value on the new router?

http://www.snapfiles.com/downloadfind.php?action=s&st=mib+browser
link

answered

eeRoot's gravatar image

eeRoot

A MIB browser is nice if you have all used MIB definitions, AND know what field you're actually looking for ...
link

answered 2011-11-30 at 17:03:43

Garry-G's gravatar image

Garry-G

New way of writing the config uses the CISCO-CONFIG-COPY-MIB ... having trouble getting it to work on Nexus 5548, but have for the time being changed to initiating it with a rsh call
link

answered 2011-12-04 at 10:41:43

Garry-G's gravatar image

Garry-G

Your answer
[hide preview]

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Tags:

×1

Asked: 11/29/2011 03:41

Seen: 277 times

Last updated: 12/15/2011 05:17