Clicky

i have installed mysql server 5.5 i am trying to connect to the server using mysql workbench

i get the message that it can not connect, i can not find anything wrong, and being unfamiliar with mysql am at a loss as where to start, any help will be appreciated

asked 12/14/2011 02:51

QuinnDester's gravatar image

QuinnDester ♦♦


8 Answers:
After you installed the server, did you start it?  Have you set a password for the mysql server?

If not, you will use username "root" and the password will be empty when you connect with Workbench.

If that does not work, please post the exact error/symptom here.
link

answered

xterm's gravatar image

xterm

yes, the server is running i can see it in the windows processes...

there is a password set it was set during installation, its a required step, wont let you proceed without it.


the error i am getting is in the attached screen shot
mysql-error.JPG
  • 34 KB
  • mysql error
mysql error
    link

    answered 2011-12-14 at 11:30:37

    QuinnDester's gravatar image

    QuinnDester

    The service does not look to be running.  Have you restarted the system since the installation?
    link

    answered 2011-12-14 at 11:56:37

    xterm's gravatar image

    xterm

    connecting through command line i get this

    Welcome to the MySQL monitor.  Commands end with ; or \g.
    Your MySQL connection id is 3
    Server version: 5.5.19 MySQL Community Server (GPL)

    Copyright (c) 2000, 2011, Oracle and/or its affiliates. All rights reserved.

    Oracle is a registered trademark of Oracle Corporation and/or its
    affiliates. Other names may be trademarks of their respective
    owners.

    Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

    mysql> help

    For information about MySQL products and services, visit:
       http://www.mysql.com/
    For developer information, including the MySQL Reference Manual, visit:
       http://dev.mysql.com/
    To buy MySQL Enterprise support, training, or other products, visit:
       https://shop.mysql.com/

    List of all MySQL commands:
    Note that all text commands must be first on line and end with ';'
    ?         (\?) Synonym for `help'.
    clear     (\c) Clear the current input statement.
    connect   (\r) Reconnect to the server. Optional arguments are db and host.
    delimiter (\d) Set statement delimiter.
    ego       (\G) Send command to mysql server, display result vertically.
    exit      (\q) Exit mysql. Same as quit.
    go        (\g) Send command to mysql server.
    help      (\h) Display this help.
    notee     (\t) Don't write into outfile.
    print     (\p) Print current command.
    prompt    (\R) Change your mysql prompt.
    quit      (\q) Quit mysql.
    rehash    (\#) Rebuild completion hash.
    source    (\.) Execute an SQL script file. Takes a file name as an argument.
    status    (\s) Get status information from the server.
    tee       (\T) Set outfile [to_outfile]. Append everything into given outfile.
    use       (\u) Use another database. Takes database name as argument.
    charset   (\C) Switch to another charset. Might be needed for processing binlog
    with multi-byte charsets.
    warnings  (\W) Show warnings after every statement.
    nowarning (\w) Don't show warnings after every statement.

    For server side help, type 'help contents'

    mysql> \r
    Connection id:    4
    Current database: *** NONE ***

    mysql>
    link

    answered 2011-12-14 at 12:52:16

    QuinnDester's gravatar image

    QuinnDester

    Okay, its definitely running, thank you for posting that.

    When you open Workbench, I assumed you put host=localhost (or 127.0.0.1) but is there an option to make a socket connection instead of a network connection to the DB?
    link

    answered 2011-12-14 at 13:02:21

    xterm's gravatar image

    xterm

    http://dev.mysql.com/doc/refman/5.5/en/can-not-connect-to-server.html

    This page definitely says that error 10061 is a network error.

    A couple of possibilities:
    - you have a firewall enabled?
    - you started the server in non-network mode, and it can only be connected to via socket (mysql client)
    link

    answered 2011-12-14 at 13:10:18

    xterm's gravatar image

    xterm

    thanks you, that link had the answer... seems there is some confusion on how windows xp resolves localhost and 127.0.0.1

    adding:

    bind-address=0.0.0.0

    to the my.ini file solved the issue
    link

    answered 2011-12-14 at 13:21:27

    QuinnDester's gravatar image

    QuinnDester

    Great job!  I hadn't read that far down yet... nice work.
    link

    answered 2011-12-14 at 15:02:02

    xterm's gravatar image

    xterm

    Your answer
    [hide preview]

    Follow this question

    By Email:

    Once you sign in you will be able to subscribe for any updates here

    By RSS:

    Answers

    Answers and Comments

    Tags:

    ×81
    ×1
    ×48

    Asked: 12/14/2011 02:51

    Seen: 228 times

    Last updated: 12/14/2011 07:02