Clicky

SBS 2003 with ISA - self signed cert worked fine for years, but wanted to add RPC over HTTPS. Purchased and installed Go Daddy SSL cert for this. Installed cert, bound cert to Default Web site. Now, still cannot connect using RPC over HTTPS, and remote access via "https://mail.mydomain.com/remote" says "Error Code: 403 Forbidden. The server denied the specified Uniform Resource Locator (URL). Contact the server administrator. (12202) ". Also trying to set ISA to allow cert by running IE Connection Wizard get response: No Certificate has been requested for the default Web site in IIS. even though it has. Does anyone have any ideas. We are going to upgrade this server within a year and use SBS Server 2011 with a hardware firewall instead of SBS, but would like to make this work for now.

asked 12/07/2011 02:18

absadmin's gravatar image

absadmin ♦♦


5 Answers:
Assuming you mean Outlook Anywhere by RPC over HTTPs... Outlook Anywhere works perfectly will with SBS 2003 self signed cert, I see no reason to introduce a third party cert to the mix.

How did you introduce the cert to SBS?
link

answered

fl_flyfishing's gravatar image

fl_flyfishing

First, in IIS created temp web site, and requested and installed cert from GoDaddy. Then deleted temp web site. I think problem may be in ISA, but recommendation was to use Intenet Connection wizard to bind cert to ISA rules. this gives me an error, even though I did set cert in IIS to Default Web page as required.

this is to be used for Outlook clients to connect to the Exchange using RPC over Https, not just for OWA or RWW. These were working fine with self signed cert. But now after installing new 3rd party cert, even these are not working.IIS shows correct cert installed to Default web site. Default web rcp settings correct per MS articles, everything looks correct but nothing works.
link

answered 2011-12-07 at 14:09:58

absadmin's gravatar image

absadmin

Check the properties of the web listener used by the RPC over HTTPs (or Outlook over the Internet, so many names for the same thing!) firewall rule, and make sure the correct certificate is being used there.
link

answered 2011-12-07 at 14:29:18

footech's gravatar image

footech

Sorry, guys. Have been working on other servers. Finally convinced boss to quit wasting resources on this old Server. We will be replacing this server with SBS 2011, and installing certs from start. I am going to close the question. Thanks to all who responded.
link

answered 2011-12-07 at 16:18:01

absadmin's gravatar image

absadmin

thanks, everyone for posting. Everything discussed kept coming back to Web listener on ISA - cert correctly installed still did not work. I am closing the question, because have convinced boss to replace this server. Thanks to all posters.
link

answered 2011-12-16 at 11:36:58

absadmin's gravatar image

absadmin

Your answer
[hide preview]

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Tags:

×1

Asked: 12/07/2011 02:18

Seen: 184 times

Last updated: 12/16/2011 03:39