Clicky

I have a Selenium VS2008/nUnit script which works fine in both IE and Firefox.  The problem is that Firefox raises a SSL cert warning everytime the test is run.  Even though I follow the Firefox directions and add a permanent exception it still occurs each run.  What's going on?  This is driving me crazy!

How can I make Firefox ignore this improper https cert?

asked 06/29/2011 05:12

Phil5780's gravatar image

Phil5780 ♦♦


3 Answers:
Which versin of FF?  What exactly did you do to add a perm exception?  You can go to the Tools->Advanced->Validation and turn it off there; that's a workaround that opens a security hole though.
link
developedtester's gravatar image

developedtester

Selenium auto generates a profile in firefox. You can create your own and specify it when starting the server. This is also handy for managing multiple browser configuration tests.
1

Create a firefox profile for selenium use

Close firefox and run firefox -p to create a new profile for use with selenium. Detailed explanation at mozilla Managing profiles


2

Open the profile and add a permanent exception for the site under test

I make a shortcut for each profile I have using firefox -no-remote -profile "<path>". The path is usually something like C:\Documents and Settings\<username>\Application Data\Mozilla\Firefox\Profiles on windows


3

Configure selenium server to use that profile in your test

Start the server with -firefoxProfileTemplate "<path to the profile>". Detailed explanation at Selenium Documentation

link
scrutinizer's gravatar image

scrutinizer

Thanks Super Scrutinizer
link
Phil5780's gravatar image

Phil5780

Your answer
[hide preview]

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Tags:

×11
×4

Asked: 06/29/2011 05:12

Seen: 581 times

Last updated: 07/06/2011 11:52