Clicky

My domain controller is a Windows Server 2008 R2.  I have it getting network time from "time.nist.gov" and all has worked just fine up until this morning.  

When I came in today, my workstations and servers were all 10 minutes ahead.  So I went and restarted the W32Time service, and it went back to the correct time.  Now, just 20 minutes ago, it jumped ahead 10 minutes again?  I restarted W32time and it is correct again.

Does anyone out there know why this would suddenly start happening?  I have not changed anything over the weekend.  Nothing was done.  I have a feeling this is going to keep happening.  Does anyone have any ideas?

asked 11/28/2011 03:59

mfehrmann's gravatar image

mfehrmann ♦♦


8 Answers:
Workstations will obviously follow server time. If the server has a clock issue set it to sync the NTP client more often
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\w32time\TimeProviders\NtpClient
Double-click on the key on the right-hand side for SpecialPollInterval
The default time period is 7 days calculated in seconds. If you wanted to change this to update every day, you would use 86400, or 60 seconds * 60 minutes * 24 hours * 1 day.

I wouldn’t recommend setting this to anything less than 4 hours worth, or your computer might get banned by the time servers.

Third party firewalls will often block the time servers, causing the sync to not work properly. If you are using McAfee or another firewall, you’ll need to use the configuration utility to unlock NPT access on UDP port 123


link

answered

Sid_F's gravatar image

Sid_F

I'm going to assume that if I don't have a Reg Key titled "SpecialPollInterval" I can just add one?  

I'm thinking this isn't a firewall issue because when I do force a sync by stopping the time service it works great.  
link

answered 2011-11-28 at 12:06:21

mfehrmann's gravatar image

mfehrmann

Is the DC virtualized? If so, then there's probably a time synchronization with the host active (which should then be disabled).
link

answered 2011-11-28 at 12:08:06

oBdA's gravatar image

oBdA

This is a virtualized server.  And oddly enough, when the time jumped, I suddenly received three "Alarm Host Connection Failures", one on each of my physical hosts.  How can I disable the synchronization to the host?
link

answered 2011-11-28 at 12:10:05

mfehrmann's gravatar image

mfehrmann

Depends on the host; for VMWare, for example, open the properties of the VMWare tools, and check thje Options tab.
link

answered 2011-11-28 at 12:11:22

oBdA's gravatar image

oBdA

That box is unchecked.  But in doing research, I found that if the servers for some reason lose connection with their host, that the time will sync anyways.  I am now investigating if the time is correct on my hosts.  

I will keep this post alive until the problem is solved, but I think this is a VMWare issue.  
link

answered 2011-11-28 at 12:13:38

mfehrmann's gravatar image

mfehrmann

I found it.  One of my hosts was not syncronizing time correctly to a time server.  It was 10 minutes fast.  I went in and changed the time server it was syncronizing too, and all seems to be well now.  
link

answered 2011-11-28 at 12:15:51

mfehrmann's gravatar image

mfehrmann

I split the points because it was a VMWare issue with the hosts time, but when I got there, it was also a firewall issue with the firewall blocking my VMWare host outbound requests for time.  I had to open up the firewall to allow outbound NTP requests and now my VMWare hosts are perfect. I'm sure the servers will now stay in sync as well.
link

answered 2011-11-28 at 12:21:18

mfehrmann's gravatar image

mfehrmann

Your answer
[hide preview]

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Tags:

×17
×1

Asked: 11/28/2011 03:59

Seen: 157 times

Last updated: 11/28/2011 06:15