Clicky

I need to set up a wireless Cisco 1242 AP as a wireless bridge/repeater (no ethernet) to another wireless Cisco 1242 AP that is connected by ethernet to the main router.  What are the settings needed for this to work and be the most efficient.

Thanks in advance, I will quickly respond to any questions.

I have played around with repeater/workgroup bridge etc and have not been successful.

asked 11/23/2011 02:13

bill30's gravatar image

bill30 ♦♦


8 Answers:
Do you need multiple VLANs, or only the default vlan?
link

answered

Garry-G's gravatar image

Garry-G

Just the default.  Everything will be set up on a generic 192.168.1.??? setup.
link

answered 2011-11-23 at 10:35:02

bill30's gravatar image

bill30

Here's some excerpt, can't put it in an AP right now, but it should cover most of the relevant config elements:

1:
2:
3:
4:
5:
6:
7:
8:
9:
10:
11:
12:
13:
14:
15:
16:
17:
18:
19:
20:
21:
22:
23:
24:
25:
26:
27:
28:
dot11 ssid MYSSID
   authentication open
   authentication key-management wpa version 2
   infrastructure-ssid
   wpa-psk ascii SOMESSIDPW

bridge irb

interface Dot11Radio1    # Change to Radio0 for 2.4GHz
 no ip address
 no ip route-cache
 !
 encryption mode ciphers aes-ccm tkip
 !
 ssid MYSSID
 station-role root      # change to "non-root" on the remote station
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
 bridge-group 1 spanning-disabled

int FastEthernet 0
 bridge-group 1
 
int BVI1                       # used for management
  ip address 192.168.1.x 255.255.255.0


link

answered 2011-11-23 at 11:20:59

Garry-G's gravatar image

Garry-G

Ill try that out and let you know!  Thanks man.
link

answered 2011-11-23 at 11:32:48

bill30's gravatar image

bill30

I wasnt able to get that to work, I was probably doing something wrong editing in my settings, but I can not be sure.  I ended up setting the first for regular AP mode and the second for repeater, but this time I didnt specify parent MAC addresses.  Its working perfectly now.  Thanks for the try though.
link

answered 2011-11-23 at 11:36:54

bill30's gravatar image

bill30

On the remote AP try the following:

conf t
int dot11radio0
 station-role repeater
end

link

answered 2011-11-23 at 13:41:19

craigbeck's gravatar image

craigbeck

Ah yes, missed the "no ethernet" for the remote ... yes, need to run dual mode there, or use e.g. Radio1 for the AP-AP connection, and Radio0 for the local clients (put both in the same bridge group and you should be fine)
link

answered 2011-11-23 at 14:37:18

Garry-G's gravatar image

Garry-G

When I took out the Parent MAC address it worked as a repeater.

link

answered 2011-11-23 at 22:50:53

bill30's gravatar image

bill30

Your answer
[hide preview]

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Tags:

×1
×3
×3
×85
×3
×50
×1

Asked: 11/23/2011 02:13

Seen: 328 times

Last updated: 12/12/2011 05:18