Clicky

Hi All,

I'm trying to connect Cisco 7921 wi-fi IP Phone to cisco Access point  but Cisco IP phone getting authentication fail error can anyone help me, What could be the problem there,

I have attached Snap of configuration of my IP phone & below is my configuration of Wi-fi Access Point
1:
2:
3:
4:
5:
6:
7:
8:
9:
10:
11:
12:
13:
14:
15:
16:
17:
18:
19:
20:
21:
22:
23:
24:
25:
26:
27:
28:
29:
30:
31:
32:
33:
34:
35:
36:
37:
38:
39:
40:
41:
42:
43:
44:
45:
46:
47:
48:
49:
50:
51:
52:
53:
54:
55:
56:
57:
58:
59:
60:
61:
62:
63:
64:
65:
66:
67:
68:
69:
70:
71:
72:
73:
74:
75:
76:
77:
78:
79:
80:
81:
82:
83:
84:
85:
86:
87:
88:
89:
90:
91:
92:
93:
94:
95:
96:
97:
98:
99:
100:
101:
102:
103:
104:
105:
106:
107:
108:
109:
110:
111:
112:
113:
114:
115:
116:
117:
118:
Current configuration : 2353 bytes
!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname CiscoAPWiFI
!
enable secret 5 XXXXXXXXXXXXXXXXXXXX
!
ip subnet-zero
!
!
no aaa new-model
dot11 vlan-name Data vlan 1
dot11 vlan-name VOIP vlan 100
!
dot11 ssid Coinop
   vlan 1
   max-associations 25
   authentication open
   authentication key-management wpa
   guest-mode
   mbssid guest-mode dtim-period 1
   wpa-psk ascii 7 XXXXXXXXXXXXXXXXXXXX
!
dot11 ssid VoiceCoinop
   vlan 100
   authentication open
   authentication key-management wpa
   wpa-psk ascii 7 XXXXXXXXXXXXXXXXXXXX
!
dot11 network-map
!
!
username XXXXXXXXXXXXXXXXXXXX password 7 XXXXXXXXXXXXXXXXXXXX
!
bridge irb
!
!
interface Dot11Radio0
 no ip address
 no ip route-cache
 !
 encryption mode ciphers tkip
 !
 encryption vlan 1 mode ciphers tkip
 !
 encryption vlan 100 mode ciphers tkip
 !
 ssid Coinop
 !
 ssid VoiceCoinop
 !
 mbssid
 speed basic-1.0 2.0 5.5 6.0 9.0 11.0 12.0 18.0 24.0 36.0 48.0 54.0
 station-role root access-point
!
interface Dot11Radio0.1
 encapsulation dot1Q 1 native
 no ip route-cache
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
 bridge-group 1 spanning-disabled
!
interface Dot11Radio0.100
 encapsulation dot1Q 100
 no ip route-cache
 bridge-group 100
 bridge-group 100 subscriber-loop-control
 bridge-group 100 block-unknown-source
 no bridge-group 100 source-learning
 no bridge-group 100 unicast-flooding
 bridge-group 100 spanning-disabled
!
interface FastEthernet0
 no ip address
 no ip route-cache
 duplex auto
 speed auto
 hold-queue 160 in
!
interface FastEthernet0.1
 encapsulation dot1Q 1 native
 no ip route-cache
 bridge-group 1
 no bridge-group 1 source-learning
 bridge-group 1 spanning-disabled
!
interface FastEthernet0.100
 encapsulation dot1Q 100
 no ip route-cache
 bridge-group 100
 no bridge-group 100 source-learning
 bridge-group 100 spanning-disabled
!
interface BVI1
 ip address 192.168.8.254 255.255.255.0
 no ip route-cache
!
ip default-gateway 192.168.8.1
ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

!
!
control-plane
!
bridge 1 route ip
!
!
!
photo.JPG (88 KB)
1 (image/jpeg)
photo-1.jpg (95 KB)
2 (image/jpeg)
photo-2.jpg (27 KB)
3 (image/jpeg)
photo-3.jpg (30 KB)
4 (image/jpeg)
photo-4.jpg (25 KB)
5 (image/jpeg)
photo-5.jpg (25 KB)
6 (image/jpeg)
photo-6.jpg (29 KB)
7 (image/jpeg)
photo-7.jpg (30 KB)
8 (image/jpeg)
photo-8.jpg (27 KB)
9 (image/jpeg)

asked 08/18/2011 02:20

vikrantambhore's gravatar image

vikrantambhore ♦♦


9 Answers:
How did you configure WPA on the handset?  Usually you can only configure WEP on the handset.
Can you check that you haven't configured WEP on the handset?
link
craigbeck's gravatar image

craigbeck

Just to be clear, I mean you can only configure WEP using the menus on the handset.  The phone does support WPA, but you need to log on to the phone's browser menu to configure it.  Only WEP or 802.1x is configurable via the handset's on-screen menu.
link
craigbeck's gravatar image

craigbeck

Hello craigbeck,

I installed USB driver & Now I am able to access Phone by GUI, but still having same issue, I think  something wrong on Access point, Please help me,

Vikrant
1:
2:
3:
4:
5:
dot11 ssid VoiceCoinop
   vlan 100
   authentication open
   authentication key-management wpa
   wpa-psk ascii 7 040B5F575E711A175D4D52
 
 
link
vikrantambhore's gravatar image

vikrantambhore

Change the WLAN Security Authentication Method from 'Open' to 'WPA-PSK' in the Phone GUI.
link
craigbeck's gravatar image

craigbeck

craigbeck Thanks for your reply, But it's working I played with phone & got success,  I have only One question

I want to use MAC filter for my ssid VoiceCoinop,  I want  to allow specific MAC-address if IP phone but only for ssid VoiceCoinop,

or want to hide ssid VoiceCoinop


I hope can do but didn't get anything yet, I hope you will help me because You are expert in Wireless :)


Vikrant
link
vikrantambhore's gravatar image

vikrantambhore

According to your config the VoiceCoinop SSID is already hidden.
To further ensure that the SSID is actually hidden, try this...

conf t
dot11 ssid Coinop
 no mbssid guest-mode dtim-period 1
end


To configure MAC authentication, have a look at this...

http://www.cisco.com/web/techdoc/wireless/access_points/online_help/eag/123-04.JA/1100/h_ap_howto_5.html
link
craigbeck's gravatar image

craigbeck

No it's Not hidden my both SSID is showing if I  searched from my LAPTOP
link
vikrantambhore's gravatar image

vikrantambhore

Can you delete the WLAN profiles from your laptop for the Coinop and VoiceCoinop SSIDs, and scan for wireless networks again to see if you can see them?

The Coinop SSID is configured to broadcast the SSID, but the VoiceCoinop SSID isn't.
link
craigbeck's gravatar image

craigbeck

Issue Fixed, Thanks
link
vikrantambhore's gravatar image

vikrantambhore

Your answer
[hide preview]

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Tags:

Asked: 08/18/2011 02:20

Seen: 825 times

Last updated: 09/14/2011 04:18