Clicky

vSphere5 not getting a proper IP address from dhcp.  Getting a 169.254 address.

asked 12/09/2011 02:03

AppleRubber's gravatar image

AppleRubber ♦♦


18 Answers:
Is it your host you're referring to? Is a network cable plugged into the adapter?
link

answered

coolsport00's gravatar image

coolsport00

No, a newly created VM does not receive a proper IP. The host is working correctly
link

answered 2011-12-09 at 10:06:28

AppleRubber's gravatar image

AppleRubber

Ok; is VMware Tools installed in the VM? Is a VM Network Port Group created on the vSwitch? Is the VM's ethernet adapter (rt-click on VM -> Edit Settings, Hardware tab, Ethernet Adapter) set to the network label/name of the vSwitch VM Network port (drop-down list in the VM settings)? Is the VM's ethernet adapter configured to be 'Connected' and 'Connect at Power on'?

~coolsport00
link

answered 2011-12-09 at 10:08:46

coolsport00's gravatar image

coolsport00

If I configure the IP staticly on the VM It will communicate correctly.  It will only get a proper dynamic address if I change the active adapter order in NIC teaming on the management network of the vSwitch.  Once I reboot the VM it comes back with the 169.254.x.x network, not the proper network.  Also i get this error after i change the adapter order.
Call "HostNetworkSystem.UpdatePortGroup" for object "networkSystem-18" on vCenter Server "CEMVSPHEREP01.apple.local" failed.
link

answered 2011-12-09 at 10:12:07

AppleRubber's gravatar image

AppleRubber

could you upload a screenshot of your vSwitch?

do you have two NICs connected to it?
link

answered 2011-12-09 at 10:28:07

hanccocka's gravatar image

hanccocka

yes 2 NIC's. screenshot uploaded
vswitch.jpg
  • 164 KB
  • vswitch
vswitch.jpg
    link

    answered 2011-12-09 at 10:45:16

    AppleRubber's gravatar image

    AppleRubber

    are these trunked on the switch?

    how have you got load balancing setup up?

    are both ports live?
    link

    answered 2011-12-09 at 10:51:21

    hanccocka's gravatar image

    hanccocka

    not trunked on the switch.

    See attachment

    Both ports are live
    teamin.jpg
    • 86 KB
    • teaming
    teamin.jpg
    teamin.jpg
    • 86 KB
    • teaming
    teamin.jpg
      link

      answered 2011-12-09 at 10:55:32

      AppleRubber's gravatar image

      AppleRubber

      If you drop vmnic4 does it work?
      link

      answered 2011-12-09 at 11:05:10

      hanccocka's gravatar image

      hanccocka

      no, it doesn't work with it removed
      link

      answered 2011-12-09 at 11:09:51

      AppleRubber's gravatar image

      AppleRubber

      okay, so if you swap and add vmnic4, but remove vmnic0.

      is the host esx server still contactable when vmnic4 removed?

      you do not havr any Tag specified on the network portgroup
      .
      link

      answered 2011-12-09 at 11:29:42

      hanccocka's gravatar image

      hanccocka

      I set the ports to trunked on the switch and it is working now.
      link

      answered 2011-12-09 at 11:45:00

      AppleRubber's gravatar image

      AppleRubber

      okay load balancing was wrong for switch.
      link

      answered 2011-12-09 at 12:05:39

      hanccocka's gravatar image

      hanccocka

      which was what I was trying to get you to establish by dropping nics in your team, glad your fixed.
      link

      answered 2011-12-09 at 12:07:07

      hanccocka's gravatar image

      hanccocka

      no, the physical switch ports needed to be trunk ports
      link

      answered 2011-12-09 at 12:08:01

      AppleRubber's gravatar image

      AppleRubber

      Thanks for all the help
      link

      answered 2011-12-09 at 12:08:08

      AppleRubber's gravatar image

      AppleRubber

      that is correct which is why I asked previously!!!
      link

      answered 2011-12-09 at 12:09:16

      hanccocka's gravatar image

      hanccocka

      Resolution was setting the hardware switch pot to trunked

      link

      answered 2011-12-09 at 12:10:06

      AppleRubber's gravatar image

      AppleRubber

      Your answer
      [hide preview]

      Follow this question

      By Email:

      Once you sign in you will be able to subscribe for any updates here

      By RSS:

      Answers

      Answers and Comments

      Tags:

      Asked: 12/09/2011 02:03

      Seen: 342 times

      Last updated: 12/17/2011 05:20

      Categories

      Related questions