Clicky

I'm new to vb, vb script.

I have an HTML page that uses an iframe to hold a different HTML page within the iframe. problem is i'm getting the actual HTML, vbscript rendering in the iframe instead of the page itself. (see picture). Why is this happening and how do i correct it? The page was rendering correctly at one point and now it's just laying over the top of the background img for the div that it's supposed to completely replace. And I'm not sure why. Though it's a little difficult if you look closely you can see that the background image for the div reads: "Contact Me", and the HTML / vb script is rendering over the top of it instead of displaying the page that the HTML is supposed to. (middle right of included image)

asked 12/13/2011 07:18

mikesExpertExchange's gravatar image

mikesExpertExchange ♦♦


5 Answers:
sorry, meant to include some details about where the line is, within that HTML that holds the iframe that's acting fishy. there is a segment in that HTML named: MAIN CONTENT. the end of this section is marked off with a series of equal signs: ==================================== about 7 or 8 lines up from the the equal signs you'll find this line:

HTML = HTML + "<iframe frameBorder=""0"" width=""300"" height=""275"" src=""http://www.blahblahblah/forms/form_cdo_v4.asp?office=48042&J=N""></iframe>"

this is the culprit. also i guess i should include the page that the iframe is supposed to render.
link

answered

mikesExpertExchange's gravatar image

mikesExpertExchange

The 'formToRender' file you posted does not have the <%@ EnableSessionState=False LANGUAGE="VBSCRIPT"%> line at the top as shown in your image.  Bring up that page directly in your browser and see if it is working properly.
link

answered 2011-12-13 at 15:38:56

DaveBaldwin's gravatar image

DaveBaldwin

Since this is a standard asp page, the header that davebaldwin mentions does not apply. I do agreed with his suggestions of calling the page by URL to see if it renders properly outside of the iframe. If it doesnt, I wonder if the server is configured to support asp pages which may then wind up being a question for your host. Do you have any other asp pages hosted on the same site?
link

answered 2011-12-13 at 17:52:02

OriNetworks's gravatar image

OriNetworks

@OriNetworks, I was trying to point out the page he posted in "formToRender.txt" is Not the same as the page shown in his image in the doc file.  At the very least that header line is missing.
link

answered 2011-12-14 at 07:06:52

DaveBaldwin's gravatar image

DaveBaldwin

i really think it was a sever error...
link

answered 2011-12-14 at 09:52:36

mikesExpertExchange's gravatar image

mikesExpertExchange

Your answer
[hide preview]

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Tags:

×104
×1
×6
×6

Asked: 12/13/2011 07:18

Seen: 475 times

Last updated: 12/15/2011 05:26